hdu5505 GT and numbers(BestCoder Round #60)

GT and numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 262 Accepted Submission(s): 75


Problem Description
You are given two numbers N and M .

Every step you can get a new N in the way that multiply N by a factor of N .

Work out how many steps can N be equal to M at least.

If N can't be to M forever,print 1 .

Input
In the first line there is a number T . T is the test number.

In the next T lines there are two numbers N and M .

T1000 , 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.

Output
For each test case,output an answer.

Sample Input
  
  
3 1 1 1 2 2 4

Sample Output
  
  
0 -1 1

Source

题意:每个n都可以乘上一个自己的因子,求最少乘几次能得到m。
分析:

如果AAA大于BBB那么显然无解。

考虑把AAABBB分解质因数。

BBB存在AAA没有的质因数也显然无解。

对于某一个AAA的质因数的次数。为了加速接近BBB,它一定是每次翻倍,最后一次的时候把剩下的加上。

那么答案就是最小的kkk使得2k∗Anum≥Bnum2^{k}*A_{num} \geq B_{num}2kAnumBnum

最后把每个质因数的答案max起来即可。(B可以是2^63,这样就得用unsigned long long了,这是个坑点)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

unsigned ll n,m;

ll gcd(ll a, ll b)
{
    if(a%b)
        return gcd(b, a%b);
    return b;
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        int ans=0;
        while(n!=m)
        {
            if(m%n){cout<<"-1"<<endl; break;}
            ll k=gcd(m/n, n);
            if(k==1){cout<<"-1"<<endl; break;}
            n*=k;
            ans++;
        }
        if(n==m) cout<<ans<<endl;
    }
    return 0;
}


2632^{63这样就要开unsigned long long。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值