In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fnare all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
代码:
import java.util.Arrays;
import java.util.Scanner;
public class Main{
static final int max=2;
static final int mod=10000;
public static long[][] multi(long a[][],long b[][]){
long res[][]=new long[max][max];
for(int i=0;i<max;i++)
Arrays.fill(res[i], 0);
for(int i=0;i<max;i++)
for(int j=0;j<max;j++)
for(int k=0;k<max;k++){
res[i][j]=(res[i][j]%mod+(a[i][k]*b[k][j])%mod)%mod;
}
return res;
}
public static long[][] quick_pow(long a[][],int n){
long res[][]=new long[max][max];
for(int i=0;i<max;i++)
for(int j=0;j<max;j++){
if(i==j){
res[i][j]=1;
}
else{
res[i][j]=0;
}
}
while(n!=0){
if((n&1)==1) res=multi(res,a);
n/=2;
a=multi(a,a);
}
return res;
}
public static void main(String[] args) {
Scanner scan=new Scanner(System.in);
long a[][]=new long[max][max];
long b[][]=new long[max][max];
a[0][0]=1; a[0][1]=1;
a[1][0]=1; a[1][1]=0;
while(scan.hasNext()){
int n=scan.nextInt();
if(n==-1) break;
b=quick_pow(a,n);
System.out.println(b[1][0]%10000);
}
}
}