Turn the corner HDU - 2438(三分+几何)

Mr. West bought a new car! So he is travelling around the city. 

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d. 

Can Mr. West go across the corner? 

Input

Every line has four real numbers, x, y, l and w. 
Proceed to the end of file. 

Output

If he can go across the corner, print "yes". Print "no" otherwise. 

Sample Input

10 6 13.5 4
10 6 14.5 4

Sample Output

yes
no

思路:

     角度三分[0,90]--h先增大后减小(车先往上开,再往下开直到平行)

     

   代码:

import java.util.Scanner;

public class Main {
	static double x,y,l,w;
	static double PI=Math.acos(-1.0);
	static double exp=1e-8;
	public static double cal(double angle){
		 double s=l*Math.cos(angle)+w*Math.sin(angle)-x;
		 double h=w*Math.cos(angle)+s*Math.tan(angle);
		 return h;
	}
    public static void main(String[] args) {
		 Scanner scan=new Scanner(System.in);
		 while(scan.hasNext()){
			 x=scan.nextDouble();
			 y=scan.nextDouble();
			 l=scan.nextDouble();
			 w=scan.nextDouble();
			 double l=0,r=PI/2;
			 while(r-l>=exp){
				 double m=(l+r)/2;
				 double mm=(m+r)/2;
				 if(cal(m)>cal(mm)){
					r=mm;
				 }
				 else{
					 l=m;
				 }
			 }
			 if(cal(r)>y||x<w||y<w){
				 System.out.println("no");
			 }
			 else{
				 System.out.println("yes");
			 }
		 }
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值