Minimum Inversion Number (线段树求逆序对+规律)

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意:

序列0~n-1这n个数,求

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1)   每种序列的逆序对数量的最小值

思路:首先求出原来序列的逆序对的数量,每次把第一个数放到最后边逆序对变化量:n-a[i]-(a[i]-1)

          为什么是这个:在第一个位置的数,比它小的有a[i]-1个,比它大的有n-a[i]个,所以放到最后边对原来序列逆序对的贡献值就是:n-a[i]-(a[i]-1)

代码:

   


import java.util.Arrays;
import java.util.Scanner;

public class Main{
	static int n;
	static final int max=5005;
	static int tree[]=new int[max<<2];
	static int arr[]=new int[max<<2];
	public static void update(int node,int l,int r,int a,int b){
		if(l==a&&r==b){
			tree[node]+=1;
			return;
		}
		int mid=(l+r)>>1;
	    if(a<=mid) update(node<<1,l,mid,a,b);
	    if(b>mid)  update(node<<1|1,mid+1,r,a,b);
	    tree[node]=tree[node<<1]+tree[node<<1|1];
	}
	public static int query(int node,int l,int r,int a,int b){
		if(l>=a&&r<=b){
			return tree[node];
		}
		int mid=(l+r)>>1;
		if(b<=mid) return query(node<<1,l,mid,a,b);
		else if(a>mid) return query(node<<1|1,mid+1,r,a,b);
		else return query(node<<1,l,mid,a,b)+query(node<<1|1,mid+1,r,a,b);
	}
    public static void main(String[] args) {
		 Scanner scan=new Scanner(System.in);
		 while(scan.hasNext()){
			 n=scan.nextInt();
			 Arrays.fill(tree, 0);
			 for(int i=1;i<=n;i++){
				 arr[i]=scan.nextInt()+1;//数组值加一,和update,query的了l,r对应起来
			 }
			 int sum=0;
			 for(int i=1;i<=n;i++){
				 int a=arr[i];
				 update(1,1,n,a,a);
				 sum+=(i-query(1,1,n,1,a));
			 }
			 int ans=sum;
			 for(int i=1;i<n;i++){
				 sum=sum+(n-arr[i])-(arr[i]-1);
				 if(sum<ans)
					 ans=sum;
			 }
			 System.out.println(ans);
		 }
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值