GCD (欧拉函数)

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6. 
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem: 
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output

For each test case,output the answer on a single line.

Sample Input

3
1 1
10 2
10000 72

Sample Output

1
6
260

题意:1<=x<=n,1<=m<=n,gcd(x,n)>=m,求满足条件的x的个数

解法:

          先找出N的约数x,并且gcd(x,N)>= M,结果为所有N/x的欧拉函数之和。

          因为x是N的约数,所以gcd(x,N)=x >= M;

   设y=N/x,y的欧拉函数为小于y且与y互质的数的个数。

   设与y互质的的数为p1,p2,p3,…,p4

   那么gcd(x* pi,N)= x >= M。

          也就是说只要找出所有符合要求的y的欧拉函数之和就是答案了。

超时代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
//求欧拉函数 
int Euler(int n)
{
	int ret=n;
	for(int i=2;i<=sqrt(n);i++)
	{
		if(n%i==0)
		{
			ret=ret/i*(i-1);
			while(n%i==0)
			  n/=i;
		}
	}
	if(n>1)
	   ret=ret/n*(n-1);
	return ret;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		int ans=0;
		for(int i=2;i<=n;i++)
		{
			if(n%i==0&&i>=m)
			{
				ans+=Euler(n/i);
			}
		}
		cout<<ans<<endl; 
	}
	return 0;
}

 

ac代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
//求欧拉函数 
int Euler(int n)
{
	int ret=n;
	for(int i=2;i<=sqrt(n);i++)
	{
		if(n%i==0)
		{
			ret=ret/i*(i-1);
			while(n%i==0)
			  n/=i;
		}
	}
	if(n>1)
	   ret=ret/n*(n-1);
	return ret;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		int ans=0;
		int sq_n=sqrt(n);
		for(int i=2;i<=sq_n;i++)
		{
			if(n%i==0)
			{
				if(i>=m)   ans+=Euler(n/i);
				if(n/i>=m) ans+=Euler(i);
			}
		}
		if(n!=1&&sq_n*sq_n==n&&sq_n>=m) ans-=Euler(n/sq_n);
		cout<<ans+1<<endl; 
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值