Color the fence


Color the fence

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to 

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint. 

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入
There are multiple test cases.
Each case the first line contains a nonnegative integer V(0≤V≤10^6).
The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).
输出
Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.
样例输入
55 4 3 2 1 2 3 4 529 11 1 12 5 8 9 10 6
样例输出
5555533
源代码如下:

#include<stdio.h>
int main()
{
int i,j,v,a[10];
while(scanf("%d",&v)!=EOF)
{
int t=0;
for(i=1;i<=9;i++)
{
scanf("%d",&a[i]);
}
int min=a[1];
for(i=1;i<=9;i++)
{
if(min>=a[i])
{
min=a[i];  
}
}
for(i=v/min;i>=1;i--)//计算最多能刷几个数字(包含相同的数字或者不同的数字)

                {
for(j=9;j>=0;j--)
{
if(v>=a[j]&&(v-a[j])/min>=i-1)//判断j数字能否被刷,且剩余的涂料可以刷剩下的i-1个数字
{
printf("%d",j);
v-=a[j];
break;
}
}
}
printf("\n");
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值