(PAT 甲级)1013 Battle Over Cities

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

分析:

该题的大意是在一个强连通图中去除一个顶点之后将原图分为多少个小的连通图(要输出的答案为连通分量-1)。

求图的连通分量时,将所有为访问过的顶点作为起点进行dfs或者bfs,同时进行计数即可求得。

这题需要注意输入输出规模较大,使用c++的流读取会超时(坑啊),以后的读取一律使用c的读取了。。。。。。  


 

#include<bits/stdc++.h>
using namespace std;
int visited[1001] = {0};
int edges[1001][1001] = {0};
int N,M,K;
void dfs(int node){
	visited[node] = 1;
	for(int i = 1;i <= N;i++){
		if(!visited[i] && edges[node][i] == 1){
			dfs(i);
		}
	}
}
int main(int argc, char const *argv[])
{
	cin >> N >> M >> K;
	for(int i = 0;i < M;i++){
		int a,b;
		 scanf("%d %d", &a, &b);
		edges[a][b] = 1;
		edges[b][a] = 1;
	}
	for(int i = 0;i < K;i++){
		int ans;
		scanf("%d",&ans);
		fill(visited,visited + 1001,0);
		visited[ans] = 1;
		int result = 0;
		for(int i = 1;i <= N;i++){
			if(!visited[i]){
				dfs(i);
				result++;
			}
		}
		cout << result - 1 << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值