1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP​ programmers. Then every NG​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP​ and NG​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP​ distinct non-negative numbers Wi​ (i=0,⋯,NP​−1) where each Wi​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP​−1 (assume that the programmers are numbered from 0 to NP​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.


Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

题目大意

// 输入
总人数N 每组M人
N1得分 N2得分 ... NN得分
N个人一开始的出场下标
// 输出
0~N-1下标对应的该人的排名

给你N个人的得分,以及一组的人数K,每个人按出场顺序先分为N/K组,如果N/K有余数,则剩下的人再为一组。

对于每一轮,每组的第一晋级下一轮,且在下一轮的出场顺序同该轮一样,该轮淘汰的所有人排名相同 = 该轮晋级人数 + 1

求每个人的最终排名


思路

  每轮有K组,K=N%M==0 ? N/M : N/M+1;

  该组被淘汰人的排名 = 当前人数%M==0 ? N/M+1 : N/M+2;


C/C++ 

#include<bits/stdc++.h>
using namespace std;
int N,M,nums[1001],result[1001],num;
int OP(vector<int>& box,int key);
int main()
{
    queue<int> all;
    vector<int> op;
    cin >> N >> M;
    for(int z=0;z<N;z++) cin >> nums[z];
    for(int z=0;z<N;z++){
        cin >> num;
        all.push(num);
    }

    while (all.size()>1){
        int len=all.size(),key=len/M;
        if(key*M!=all.size()) key++;
        for(int z=0;z<len;z++){
            op.push_back(all.front());
            all.pop();
            if(op.size()==M || z==len-1) all.push(OP(op,key+1));
        }
    }
    result[all.back()] = 1;
    cout << result[0];
    for(int z=1;z<N;z++) cout << " " << result[z];
    return 0;
}
int OP(vector<int>& box,int key)
{
    int op = box.front();
    for(int x:box) if(nums[x]>nums[op]) op = x;
    while (!box.empty()){
        if(box.back()!=op) result[box.back()] = key;
        box.pop_back();
    }
    return op;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值