hdu Junk-Mail Filter 并查集的合并与删除

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3547    Accepted Submission(s): 1079


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

 

Sample Input
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

 

Sample Output
Case #1: 3 Case #2: 2
 

 

Source
 

 

Recommend
lcy

 题目的意思大概就是有N 封邮,编号 0 -> N-1,  然后有两种操作,  M : 合并操作, 2 种邮件合并为一种;S  : 分离操作, 将一封邮件独立出去单独占一个集合,

最后题目要求统计集合的个数.   从这里可以很容易的看出这是一个并查集的题目, 不过按朴素方法来做的一般都会TLE.

加上数据量很大,  不要使用 cin , 会超时, 而且一般来说G ++ 和C++ 在处理大量数据的时候会1倍的时差 !!! 所以一般建议使用C++ 提交代码.

对于M操作,进行合并,对于S操作,进行删除,悲催的没有想到怎么删除,看别人的吧,

思想:删除操作就是用其他(用不到的)的点代替该点,JUST AND ONLY SO!!原集合中的该点JUST

作为其它某些点的桥梁,通向根节点的桥梁,也就是ancestor[x]不变!若再删除,再用其它点代替,那么

曾经的替代品也成了桥梁!!

最后注意:其中删除操作还可以直接将ancestor[i]=ind++;但是,虽然最后的总集合数目是正确的,但是,每个点所属的集合貌似是不正确的。要注意

#include <stdio.h>
#include <string.h>

#define N 100002
#define M 1000002

//-----Union_Find_Set------------------
int ancestor[N+M];
int replace[N],ind;
void Sinit(int n)
{
    int i;
    for(i=0;i<n;i++)
    {
        ancestor[i]=i;
        replace[i]=i;
    }
    ind=n;
}
int Sfind(int x)
{
    if(x!=ancestor[x])
        ancestor[x]=Sfind(ancestor[x]);
    return ancestor[x];
}
void Sunion(int x,int y)
{
    int ancex=Sfind(x),ancey=Sfind(y);
    ancestor[ancex]=ancey;
}
void Sdelete(int x)
{
    replace[x]=ind;
    ancestor[ind]=ind;
    ++ind;
}
//--------------------------------------------

bool flag[N+M];

int main()
{
    int n,m;
    int i,x,y,ans,ance,cas=0;
    char c[2];

//    freopen("input.txt","r",stdin);
    while(scanf("%d %d",&n,&m) && n)
    {
        Sinit(n);
        for(i=0;i<m;i++)
        {
            scanf("%s",c);
            if(c[0]=='M')
            {
                scanf("%d %d",&x,&y);
                Sunion(replace[x],replace[y]);
            }
            else
            {
                scanf("%d",&x);
                Sdelete(x);
            }
        }

        memset(flag,false,sizeof(flag)); ans=0;
        for(i=0;i<n;i++)
        {
            ance=Sfind(replace[i]);
            if(!flag[ance])
            {
                ++ans; 
                flag[ance]=true;
            }
        }

        printf("Case #%d: %d\n",++cas,ans);
    }

    return 0;
}

  

转载于:https://www.cnblogs.com/lmnx/archive/2012/05/03/2481277.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值