POJ 1704 Georgia and Bob ( 阶梯博弈 模板 )

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win

Georgia will win

题意:n个棋子,双方轮流走,只可以把棋子向左行动,且不可以跳过其他棋子,直到一方无法移动,假设双方足够聪明。

思路:阶梯博弈,n个棋子,

奇数的话则提取出第一个,然后其余的两个为一组,计算Nim和。

偶数的话,每两个为一组,计算Nim和。

在一组棋子中,如果对手移动前一个,你可以对后一个移动相同的步数,所以一对棋子的前一个和后一个之间有多少个空位置对最终结果的影响,这样就转化成了求Nim和

在同一对棋子中,如果对手移动前一个,你总能对后一个移动相同的步数,所以一对棋子的前一个和前一对棋子的后一个之间有多少个空位置对最终的结果是没有影响的。 Nim博弈(3堆石子,双方轮流取一堆中的任意一个)

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int n,k;
int s[1010];
int main()
{
   int t;
   scanf("%d",&t);
   while(t--){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&s[i]);
    sort(s+1,s+n+1);
    int ans;
    if(n%2==0){
        ans=s[2]-s[1]-1;
        for(int i=4;i<=n;i+=2) ans=ans^(s[i]-s[i-1]-1);
    }
    else{
        ans=s[1]-1;
        for(int i=3;i<=n;i+=2) ans=ans^(s[i]-s[i-1]-1);
    }
    if(ans==0)  printf("Bob will win\n");
    else        printf("Georgia will win\n");
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值