Georgia and Bob (阶梯博弈)

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output
For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17
Sample Output
Bob will win
Georgia will win

题解:

Georgia和Bob两个人玩游戏,他们设计了如下的的棋盘,有N块格子,从1开始标号。棋盘上不同的格子上有一些棋子,其中每个格子只能有一个棋子。然后他们开始轮流移动棋子,每次选择其中的一个向左移动,每次最少移动一格,最多只能移到前一个的右边。(第一个只能移到1上)。当谁先不能移动棋子便算输。Gerogia先移动。

输入为T组样例,每个样例有n个棋子,位置分别为p1,p2,……pn

阶梯博弈不详细再说了,就是奇数的尼姆博弈

这题要怎么和阶梯博弈扯上关系?

如果是偶数两两配对,如果是奇数,在前面加a[0]=0,再继续两两配对。

(例如:

1 5 6 7 9 12 14 17

1--5 6--7 9--12 14--17

1 2 3 4 5 6 7

这样发现与偶数时无关,符合阶梯博弈)

如果先手将左端数向左移,那么后手将右端数移相同数量的空格。这样会发现只与其间隔数有关。

这也就像nim取石,有n堆石子,每次至少取走其中一堆的至少一个,谁最先没石子取就输,各个异或。

注意!!!输入的数要排序一下

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	int t , n , a[1000],F[1000],ans,res;
	scanf("%d" , &t);
	while(t--)
	{
		ans = 0,res = 0;
		scanf("%d" , &n);
		for(int i = 1; i <= n ; i++)
		{
			scanf("%d" , &a[i]);
		}
		sort(a+1,a+n+1);
		if(n % 2 == 1)
		{
			a[0] = 0;
			for(int i = 1 ; i <= n ; i+=2)
			{
				F[ans] = a[i] - a[i-1]-1;
			
			//	cout <<"F[ans] = "<< F[ans]<<endl;
				ans++;
			}
		}
		else
		{
			for(int i = 1 ; i < n ; i+=2)
			{
				F[ans++] = a[i+1] - a[i]-1;
			}	
		}
		for(int j = 0 ; j < ans ; j++)
		{
			res ^= F[j];
			
		}
		if(res == 0)
		{
			printf("Bob will win\n");
		}
		else
		{
			printf("Georgia will win\n");
		}
	}
	
	return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值