POJ 1704:Georgia and Bob 阶梯博弈

2 篇文章 0 订阅

Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8718 Accepted: 2781

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

题意是有一个1*x的棋盘,上面有n个棋子,每一个棋子占一个空,每一个空只能被一个棋子占,G和B两个人每回合取一个棋子往左移,不能越其他棋子,当没有棋子可以移动的时候,游戏结束。

博弈题自己做的也很少。。。突然发现自己无论哪一方面题都做得好少。。。

通过这次CTF才知道了阶梯博弈。。。之前Nim博弈的时候就要做到这类问题了,阶梯博弈就是把位置为奇数的阶梯上的个数,看成是Nim博弈。。。

然后这道题就是把两个棋子中间的空格看成了阶梯上面的数量,每一次棋子向左移,相当于阶梯上的数量向右移。

代码:

#pragma warning(disable:4996)
#include <iostream>
#include <functional>
#include <algorithm>
#include <cstring>
#include <vector>
#include <string>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <deque>
#include <set>
#include <map>
using namespace std;
typedef long long ll;

#define INF 0x3fffffffffffffff

const ll mod = 1e9 + 7;
const int maxn = 1005;

int n;
int val[maxn],spa[maxn];

void solve()
{
	int i, j, k;
	scanf("%d", &n);
	for (i = 1; i <= n; i++)
	{
		scanf("%d", &val[i]);
	}
	sort(val + 1, val + n + 1);
	val[0] = 0;
	for (i = 1; i <= n; i++)
	{
		spa[i] = val[i] - val[i - 1] - 1;
	}
	int s = 0;
	for (i = n; i >= 1; i -= 2)
	{
		s ^= spa[i];
	}
	if (s)
	{
		puts("Georgia will win");
	}
	else
	{
		puts("Bob will win");
	}
}

int main()
{
	int t;
	scanf("%d", &t);
	
	while(t--)
		solve();

	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值