POJ 2250 Compromise(文章的最长公共子序列LCS)

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 


Therefore the German government requires a program for the following task: 
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 


Your country needs this program, so your job is to write it for us.
Input
The input will contain several test cases. 
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
Input is terminated by end of file.
Output
For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.
Sample Input
die einkommen der landwirte 
sind fuer die abgeordneten ein buch mit sieben siegeln 
um dem abzuhelfen 
muessen dringend alle subventionsgesetze verbessert werden 

die steuern auf vermoegen und einkommen 
sollten nach meinung der abgeordneten 
nachdruecklich erhoben werden 
dazu muessen die kontrollbefugnisse der finanzbehoerden 
dringend verbessert werden 
#
Sample Output
die einkommen der abgeordneten muessen dringend verbessert werden

题意:

       给你两段由空格分隔的语句, 要你求该两段语句的最长公共子序列. 且随便输出一个解即可. 注意每个单词需要看成我们一般处理字符串子序列的一个单独字符. 即每个单词是一个整体.
思路:

       与往常计算最长公共子序列一样的方式即可,利用string数组(等效于二维字符数组) 然后用DFS输出序列即可.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdio>
typedef long long ll;
#define N 105
using namespace std;

string s1[N];
string s2[N];
int n,m;
int dp[N][N];

void dfs(int i,int j)
{
    if(i==0 || j==0) return ;
    else if(s1[i]==s2[j])
    {
        dfs(i-1,j-1);
        cout<<s1[i]<<" ";
    }
    else
    {
        if(dp[i-1][j]>dp[i][j-1])
            dfs(i-1,j);
        else dfs(i,j-1);
    }
}

int main()
{
    string s;
    while(cin>>s)
    {
        n=m=0;
        if(s!="#")
        {
            s1[++n]=s;
            while(cin>>s && s!="#")
            {
                s1[++n]=s;
            }
        }
        while(cin>>s && s!="#")
        {
            s2[++m]=s;
        }

        //递推过程
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            if(s1[i]==s2[j])
                dp[i][j]=dp[i-1][j-1]+1;
            else
                dp[i][j]=max(dp[i-1][j], dp[i][j-1]);
        }

        //输出结果
        dfs(n,m);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值