HDU - 4006 The kth great number (优先队列 小根堆)

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3

Hint

Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).

题意:I 为往一个队列中添加元素,num, Q为输出该队列的第k大元素

思路:优先队列,刚开始我是想用大根堆(默认)来解决,但是如果k很大的话,每次弹出了队首元素,还需要记录。不妨采用小根堆,题目的k已经知道,让次队列永远只保持有k个元素。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdio>
#include <functional> //小根堆特有头文件
typedef long long ll;
#define N 1005
using namespace std;
priority_queue<int,vector<int>,greater<int> >a;
int main()
{
    char ch;
    int n,k;
    while(scanf("%d%d",&n,&k)==2)
    {
        while(!a.empty())
            a.pop();
        while(n--)
        {
            int num;
            getchar();
            scanf("%c",&ch);
            if(ch=='I'){
                scanf("%d",&num);
                if(a.size()<k)
                    a.push(num);
                else
                {
                   int  mid=a.top();
                    if(num>mid){
                        a.pop(); //队列头部数据出队
                        a.push(num);//在队列尾部增加num数据
                    }
                }
            }
            else{
                num=a.top();
                printf("%d\n",num);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值