1007(优先队列)

Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output
The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input
  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q

Sample Output
  
  
1 2 3

题目大概:

要求我们求出所给数列的第k大数。

思路:

刚开始,我是用树状数组做的,再加上二分,但是超时了。

因为用二分必须要有序,所以我用了排序,我感觉就是排序超时,但没找到解决的好办法,就用了这个优先队列,毕竟看到这个题,很少有人会想到树状数组。

代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

struct poin
{
    int v;
    friend bool operator<(poin a,poin b)
    {
        return a.v>b.v;
    }
};

int main()
{
    int n,k;int l;
    poin s;
    while(~scanf("%d%d",&n,&k))
    {
        priority_queue<poin>q;

        char p[2];
        while(n--)
        {


        scanf("%s",p);
        if(p[0]=='I')
        {
            scanf("%d",&l);
            s.v=l;
            q.push(s);
            int t=q.size();
            if(t>k)q.pop();

        }
        else
        {   poin su=q.top();
            printf("%d\n",su.v);
        }
        }
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值