POJ 3468 A Simple Problem with Integers 线段树区间更新 (lazy策略 值在基础上相加或相减)

Description


You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.


Input


The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.


Output


You need to answer all Q commands in order. One answer in a line.


Sample Input


10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output


4
55
9

15题意:

思路:线段树区间更新的模板,lazy策略:延迟标记 (或者说懒惰标记), 简单来说就是每次更新的时候不要更新到底,
用延迟标记使得更新延迟到下次需要更新或者询问的时候。

lazy:更新到某个区间的时候,就先给这个区间打上标记,标记内容是需要更新的值,并把子区间的值改为子区间对应的值,清除该区间的lazy标记;然后return,不去更新子区间。当下一次更新或查询等需要访问该区间的子区间的时候再把该区间的lazy和其他信息送回子区间。(因为不更新到底所以是lazy)

#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>
const int maxn = 111111;
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long ll;
ll add[maxn<<2];
ll sum[maxn<<2];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
    if(add[rt])                  //节点rt有标记
    {
        add[rt<<1]=add[rt];           //更新左节点信息
        add[rt<<1|1]=add[rt];         //更新右节点信息
        sum[rt<<1]=add[rt]*(m-(m>>1));   //给左子节点打标记
        sum[rt<<1|1]=add[rt]*(m>>1);    //给右子节点打标记
        add[rt]=0;                     //清楚rt的标记1
    }
}
void build(int l,int r,int rt)
{
    add[rt]=0;
    if(l==r)
    {
        //scanf("%lld",&sum[rt]);
        sum[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R)   //完全覆盖
    { 
        add[rt]=c;     //更新节点信息
        sum[rt]=(ll)c*(r-l+1);  //给节点打延迟标记
        return ;
    }
    pushdown(rt,r-l+1);     //下传延迟标记
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(m<R)  update(L,R,c,rson);
    pushup(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        return sum[rt];
    }
    pushdown(rt,r-l+1);
    int m=(l+r)>>1;
    ll ret=0;
    if(L<=m) ret+=query(L,R,lson);
    if(m<R)  ret+=query(L,R,rson);
    return ret;
}
int main()
{
    int N,Q,t,num=0;
    scanf("%d",&t);
    while(num<t)
    {
        num++;
        scanf("%d%d",&N,&Q);
        build(1,N,1);
        while(Q--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1,N,1);
        }·   
        printf("Case %d: The total value of the hook is %d.\n",num,query(1,N,1,N,1));
    }
    return 0;
 
}

 

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值