HDU1022 Train Problem I(模拟栈)

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
在这里插入图片描述
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input
3 123 321
3 123 312

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.

题目大意:给定一个栈序列,能否得到给定的出栈序列。如果能,输出"Yes.",随后输出按顺序输出入栈出栈操作;否则输出"No."。每个样例最后输出FINISH。

os:第一次用java做题,还有好多地方需要学习。。

思路:char stack[ ]模拟栈、tag[ ]保存入栈出栈操作、j指针指向第二个序列的当前位置并初始化为0。

  1. 遍历第一个序列。
  2. 对于每个字符,先入栈。如果栈顶元素 == s2.charAt(j),出栈,同时j指针右移。
  3. 最后判断栈是否为空:如果空,输出"Yes.“以及tag数组;否则输出"No.”。然后输出FINISH。

代码如下:

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		int n;
		Scanner sc = new Scanner(System.in);
		String s1, s2;
		while (sc.hasNextInt()) {
			n = sc.nextInt();
			s1 = sc.next();
			s2 = sc.next();
			char[] stack = new char[n];/* 模拟栈 */
			int[] tag = new int[2 * n];/* 记录答案 */
			int top = 0, i, j = 0;
			int cnt = 0;
			for (i = 0; i < s1.length(); i++) {
				stack[top++] = s1.charAt(i);/* 先入栈 */
				tag[cnt++] = 1;/* 1:入栈  0:出栈 */
				while (top > 0 && stack[top-1] == s2.charAt(j)) {
					top--;
					j++;
					tag[cnt++] = 0;
				}
			}
			if (top == 0) {
				System.out.println("Yes.");
				for (i = 0; i < cnt; i++)
					System.out.println(tag[i] == 1 ? "in" : "out");
			} else 	System.out.println("No.");
			System.out.println("FINISH");
		}
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值