Trailing Zeroes

https://cn.vjudge.net/contest/173312#problem/C

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible



解析:本题求末尾为0的个数,即n!内有多少个2和五的倍数(很显然2的倍数远大于5,即求5的倍数)。在0~0x7fffffff内用二分法逐渐逼近 。最后注意判断结束条件和最后左右值的选取。


代码:

#include<cstdio>
#include<algorithm>
#define N 0x7fffffff
using namespace std;
int judge(int n)
{
	int t=0;
	while(n){
		t+=n/5;
		n/=5;
	}
	return t;
}
int main()
{
    int T,x=1;
	scanf("%d",&T);
	while(T--){
		int n,left=0,right, mid;
		right=N;
		scanf("%d",&n);
		while(left<=right){
			mid=(left+right)/2;
			if(judge(mid)>=n){
				right=mid-1;
			}
			else {
				left=mid+1;
			}
		}
		if(judge(left)==n) printf("Case %d: %d\n",x,left);
		else printf("Case %d: impossible\n",x);
		x++;
	}
	
 } 
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值