Apkinspector是出现错误:No module named ipapi

错误No module named ipapi:解决办法

把androguard/androlyze.py文件中:

import IPython.ipapi  
from IPython.Shell import IPShellEmbed  
替换成:  
from IPython.frontend.terminal.embed import InteractiveShellEmbed  
from IPython.config.loader import Config  
 
再把  
ipshell = IPShellEmbed(banner="Androlyze version %s" % misc.ANDROLYZE_VERSION)  
ipshell()  
替换成:  
cfg = Config()  
ipshell = InteractiveShellEmbed(config=cfg, banner1="Androlyze version %s" % androconf.ANDROGUARD_VERSION)  
ipshell() 


过程:

AndroidAnalysisGUI:This is a guide to get the alpha release of Android Analysis GUI. It has only been tested on Linux.

1. Install Qt SDK:
    (1)Download the QtSDK (qt-opensource-linux-x86-5.2.1.run from "http://qt-project.org/downloads") and install it using root permission.
        sudo ./qt-opensource-linux-x86-5.2.1.run
    (2)Configure the environment variable.
    Add these to the end of the /etc/profile:
        QTDIR=/opt/QtSDK/Desktop/Qt/473/gcc
        PATH=$QTDIR/bin:$PATH
        LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
        export QTDIR PATH LD_LIBRARY_PATH
    Then save and exit:
    Execute the “source /etc/profile” , and “sudo updatedb” at last.
    If you can execute the “qmake –v” and can look at the version information, the Qt is installed successfully.

2. Install SIP: sudo apt-get install python-sip
    (sip-4.15.5.tar.gz from "http://www.riverbankcomputing.co.uk/software/sip/download")
    (1)Firstly, you should install the python-dev, or there’are errors when executing “make”.
        sudo apt-get install python-dev
    (2)python configure.py (sudo tar -zxvf sip-4.15.5.tar.gz /folder)
    (3)make
    (4)make install

3. Install PyQt4: sudo apt-get install python-qt4
    (PyQt-x11-gpl-4.8.4.tar.gz from "http://www.riverbankcomputing.co.uk/software/pyqt/download")
    (1)tar xvfz PyQt-x11-gpl-4.8.4.tar.gz
    (2)python configure.py -g (then select "yes")
    (3)make
    (4)make install

4. Install pydot: sudo apt-get install python-pydot
    (pydot-1.0.25.tar.gz from "http://code.google.com/p/pydot/downloads/list")
    (1) python setup.py install

5. Install Graphviz: sudo apt-get install graphviz
    (graphviz-2.28.0.tar.gz from "http://www.graphviz.org/Download..php")
    (1) ./configure --with-ortho=yes
    (2) make
    (3) make install

6. Install apktool:
    (http://code.google.com/p/android-apktool/)
    # Linux:
       (1). Download apktool-install-linux-* file
       (2). Download apktool-* file
       (3). Unpack both to /usr/local/bin directory (you must have root permissions)

7. Run this tool:
    python startQT.py

[Others]: if you miss python lib dependency, you should install with the following two steps:
    (1) sudo apt-get install ipython
    (2) sudo apt-get install python-scipy  


展开阅读全文

没有更多推荐了,返回首页