[简单思维题]Distances to Zero

题目描述

You are given the array of integer numbers a0, a1, ..., an - 1. For each element find the distance to the nearest zero (to the element which equals to zero). There is at least one zero element in the given array.

输入

The first line contains integer n (1 ≤ n ≤ 2·105) — length of the array a. The second line contains integer elements of the array separated by single spaces ( - 109 ≤ ai ≤ 109).

输出

Print the sequence d0, d1, ..., dn - 1, where di is the difference of indices between i and nearest j such that aj = 0. It is possible that i = j.

样例输入

9
2 1 0 3 0 0 3 2 4

样例输出

2 1 0 1 0 0 1 2 3

题目大意:对于给定的数组,对数组中的每一个元素,求其与0的最近距离

思路:枚举距离k,从0开始枚举不断增加一直到arr[i-k]或arr[i+k]为0,就认为找到了最近距离,直接输出就好了

AC代码:
#include<cstdio>
int a[200005];
int ans[200005];
 
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
    }
    for(int i=1;i<=n;i++){
        int k=0;
        while(1){
            if(i-k>=1&&a[i-k]==0){
                ans[i]=k;
                break;
            }
            if(i+k<=n&&a[i+k]==0){
                ans[i]=k;
                break;
            }
            k++;
        }
    }
    printf("%d",ans[1]);
    for(int i=2;i<=n;i++){
        printf(" %d",ans[i]);
    }
    printf("\n");
    return 0;
}

 

转载于:https://www.cnblogs.com/lllxq/p/8330642.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值