HDU 1158 Employment Planning


Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2763    Accepted Submission(s): 1091


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
   
   
3 4 5 6 10 9 11 0
 

Sample Output
   
   
199
 

Source
 

Recommend
Ignatius
 

题意:某公司经理知道n个月中每个月所需要员工的最少人数,但是考虑到:每雇佣一个人要花费hr美元、每员工月薪为sl美元、没解雇一员工需要花费fr美元,经理发现不同的雇佣方式(每月雇佣人数不同)导致总的花费不同。该经理想知道公司n个月的最小花费。

#include<stdio.h>
int ren[1007],dp[1007][1007];
int main()
{
    int month;
    while(scanf("%d",&month),month)
    {
        int hire,sals,fire,i,j,k,max_ren=-1,cost;
        scanf("%d%d%d",&hire,&sals,&fire);
        for(i=1;i<=month;i++)
        {
            scanf("%d",&ren[i]);
            if(max_ren<ren[i])
            max_ren=ren[i];
        }
        for(j=ren[1];j<=max_ren;j++)
        dp[1][j]=j*hire+sals*j;

        for(i=2;i<=month;i++)
        for(j=ren[i];j<=max_ren;j++)
        {
            int min=9999999;
            for(k=ren[i-1];k<=max_ren;k++)
            {
               if(k>j)
               {
                   cost=dp[i-1][k]+(k-j)*fire+sals*j;
               }
               else
               {
                   cost=dp[i-1][k]+(j-k)*hire+sals*j;
               }
                if(cost<min)
                min=cost;
            }
            dp[i][j]=min;
        }
        int min_cost=99999999;
        for(i=ren[month];i<=max_ren;i++)
        if(dp[month][i]<min_cost)
        min_cost=dp[month][i];
        printf("%d\n",min_cost);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值