HDU 2577 How to Type 简单dp题

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5169    Accepted Submission(s): 2307


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8

The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

//简单dp题,可我做起来好艰难,哎哎,智商果然是不够用的。。。不过好像是第一道自己想出来的dp, 之前都是各种套模板,还是值得高兴的
//定义二维dp数组,第一维表示字符串长度,第二维表示大小写状态,长度为2. dp[i][0]代表i-1个字符且大写状态时最少敲击数,dp[i][1]代表i-1个字符且小写状态时最少敲击数
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <cctype>
using namespace std;

int main()
{
    int t;
    int dp[300][2];
    char s[300];

    scanf("%d", &t);
    while(t--)
    {
        scanf(" %s", s);

        int n = strlen(s);
        memset(dp, 0x3f, sizeof dp); //dp数组置为极大值
        dp[0][0] = 1,  dp[0][1] = 0; //初始状态赋值,因为打开大写,所以dp[0][0] = 1
        for(int i = 0; i < n; i++) //状态转移
        {
            if(isupper(s[i]))
            {
                dp[i+1][0] = min(dp[i][0] + 1, dp[i][1] + 2);
                dp[i+1][1] = min(dp[i][0] + 2, dp[i][1] + 2);
            }
            if(islower(s[i]))
            {
                dp[i+1][0] = min(dp[i][0] + 2, dp[i][1] + 2);
                dp[i+1][1] = min(dp[i][0] + 2, dp[i][1] + 1);
            }
        }

        printf("%d\n", min(dp[n][0] + 1, dp[n][1])); 
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值