HDU 2577

How to Type
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4829 Accepted Submission(s): 2183

Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input

3
Pirates
HDUacm
HDUACM

Sample Output

8
8
8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

此题用到了DP的思想。假设依次读取了i个字母,那么当要读到i+1个字母时,假设前i个字母已经是最优解状态,那么对i+1个字母的操作就涉及开关caps,按不按shift,录入字这几种操作。由于最开始有开关caps两种状态,所以要存这两种起始的情况。又由于假设A+B个字母中前A个字母已经是最优解,那么问题就变成了求解后B个字母的最优解,那么后B个字母起始又有caps关开两种情况,推广到所有的字母,可知,应该用两个数组来表示caps开关两种情况的最优解。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
//#define LOCAL
using namespace std;

char s[111];
int dpb[111];
int dpa[111];

int main()
{
#ifdef LOCAL
    freopen("data.in","r",stdin);
    freopen("data.out","w",stdout);
#endif // LOCAL
    int N;
    scanf("%d",&N);
    while(N--){
        scanf("%s",s);
        int i,j;

        memset(dpa,0,sizeof(dpa));
        memset(dpb,0,sizeof(dpb));
        dpb[0] = 1;//开灯

        for(i = 0;s[i]!='\0';i++){
            if(s[i]>='a'&&s[i]<='z'){
                dpa[i+1] = min(dpa[i]+1,dpb[i]+2);
                dpb[i+1] = min(dpa[i]+2,dpb[i]+2);
            }
            if(s[i]>='A'&&s[i]<='Z'){
                dpa[i+1] = min(dpa[i]+2,dpb[i]+2);
                dpb[i+1] = min(dpa[i]+2,dpb[i]+1);
            }
        }
        dpb[strlen(s)]++;//关灯
        printf("%d\n",min(dpa[strlen(s)],dpb[strlen(s)]));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值