HDU 5724 Chess (sg函数)

Chess

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5724

Description


Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.

Input


Multiple test cases.
The first line contains an integer T(T≤100), indicates the number of test cases.
For each test case, the first line contains a single integer n(n≤1000), the number of lines of chessboard.
Then n lines, the first integer of ith line is m(m≤20), indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1≤pj≤20) followed, the position of each chess.

Output


For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.

Sample Input


2
1
2 19 20
2
1 19
1 18

Sample Output


NO
YES


题意:


在 n*20 的棋盘上有若干棋子,棋子每次只能水平地移动到右边第一个空位.
两人以最优策略轮流走,求先手是否能取胜.


题解:


只考虑单行的情况,由于最多只有20个位置,所以可以状态压缩.
对于每个状态,考虑它能够转移到的状态,求sg值即可.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 101000
#define mod 100000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int sg[1<<21];

bool vis[25];
int get_sg(int state) {
    /*右边最后一个空位置*/
    int last = -1;
    memset(vis, 0, sizeof(vis));
    for(int i=0; i<20; i++) {
        if(state & (1<<i)) {
            if(last == -1) continue;
            int nextstate = state ^ (1<<last) ^ (1<<i);
            vis[sg[nextstate]] = 1;
        } else {
            last = i;
        }
    }

    for(int i=0; i<25; i++) if(!vis[i]) {
        return i;
    }
}

int main(int argc, char const *argv[])
{
    //IN;

    for(int s=0; s<(1<<20); s++)
        sg[s] = get_sg(s);

    int t; cin >> t;
    while(t--)
    {
        int n; scanf("%d", &n);

        int ans = 0;
        while(n--) {
            int m; scanf("%d", &m);
            int state = 0;
            while(m--) {
                int x; scanf("%d", &x);
                state |= 1 << (20-x);
            }
            ans ^= sg[state];
        }

        if(ans) puts("YES");
        else puts("NO");
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5767597.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值