UVALive 6858 Frame (模拟)

Frame

题目链接:

http://acm.hust.edu.cn/vjudge/contest/130303#problem/D

Description


http://7xjob4.com1.z0.glb.clouddn.com/17e6574035df3f9b6d1fc6dfd8b650ac

Input


The input file contains several test cases, each of them as described below.
The first line contains 2 integers — X and Y (3 ≤ X ≤ 10^6, 3 ≤ Y ≤ 10^6). The second line
contains integer N — the number of tile types to be analyzed (1 ≤ N ≤ 1000). Each of following N
lines contains one integer, not exceeding 10^6. We designate with AK the integer on the (k + 2)-th line of the input file.

Output


For each test case, your goal is to print N lines, where the K-th line should contain the word ‘YES’, if it is possible to tile the frame with size X × Y with tiles AK × 1, and the word ‘NO’ otherwise.

Sample Input

5 6
2
3
4

Sample Output

YES
NO

Source


2016-HUST-线下组队赛-4


题意:


在XY的矩形的最外圈放若干个 A1 的小矩形,判断对于给定的A能够恰好完全覆盖.


题解:


考虑最上面一行的情况,第一块小矩形要么从#(1,1)开始,要么从#(1,2)开始(留出第一格给竖的矩形).
确定第一块的位置后,后面的摆放情况是固定的,所以依次判断一下是否合法即可.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#define LL long long
#define maxn 101000
#define inf 0x3f3f3f3f
#define mod 1000000007
#define mid(a,b) ((a+b)>>1)
#define eps 1e-8
#define IN freopen("in.txt","r",stdin);
using namespace std;

int n;

int x,y;
bool solve(int a) {
    int last1 = x % a;
    if(last1 > 1) return 0;
    if(last1 == 1) {
        int last2 = y % a;
        if(last2 > 1) return 0;
        if(last2 == 1) return 1;
        if(last2 == 0) return (y-2) % a == 0;
    }
    if(last1 == 0) {
        int last2 = (y-1) % a;
        if(last2 > 1) return 0;
        if(last2 == 1) return 1;
        if(last2 == 0) return (x-2) % a == 0;
    }
}

bool solve2(int a) {
    int last1 = (x-1) % a;
    if(last1 > 1) return 0;
    if(last1 == 1) {
        int last2 = y % a;
        if(last2 > 1) return 0;
        if(last2 == 0) return 1;
        if(last2 == 1) return x % a == 0;
    }
    if(last1 == 0) {
        int last2 = (y-1) % a;
        if(last2 > 1) return 0;
        if(last2 == 0) return 1;
        if(last2 == 1) return y % a == 0;
    }
}

int main()
{
    //IN;

    while(scanf("%d %d", &x,&y) != EOF)
    {
        swap(x,y);
        int n; scanf("%d", &n);
        while(n--) {
            int a; scanf("%d", &a);
            if(solve(a) || solve2(a)) puts("YES");
            else puts("NO");
        }
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5811188.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值