Happy 2006

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9…are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input
The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output
Output the K-th element in a single line.

Sample Input
2006 1
2006 2
2006 3

Sample Output
1
3
5
思路:由欧几里得gcd(a,b)=gcd(a+b*t,b),枚举小于m的所有互素的数,然后这些数加上一个m也与m互素,可以由这样的周期性找到第k个的答案。

如果a与b互素,则b×t+a与b也一定互素,如果a与b不互素,则b×t+a与b也一定不互素
故与m互素的数对m取模具有周期性,则根据这个方法我们就可以很快的求出第k个与m互素的数
假设小于m的数且与m互素的数有k个,其中第i个是ai,则第m×k+i与m互素的数是k×m+ai

# include <cstdio>
# include <iostream>
using namespace std;
typedef long long ll;
ll gcd (ll a,ll b)//欧几里得算法
{
    return b ? gcd(b,a%b) : a;
}
ll n[1000010],p,m,i,j;
ll k,a,ans,pos;
int main ()
{
    while (cin >> m >> k)
    {
        p = 0;
        for (i=1; i<=m; ++i)
            if (gcd(i,m) == 1)
            n[++p] = i;
        a = k / p;
        pos = k % p;
        if (!pos)
        {
            pos = p;
            a--;
        }
        ans = a*m + n[pos];
        cout << ans << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值