HDU 1539 Shredding Company dfs枚举每位数字的空格

Shredding Company

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 682 Accepted Submission(s): 225

Problem Description
You have just been put in charge of developing a new shredder for the Shredding Company. Although a “normal” shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics.
The shredder takes as input a target number and a sheet of paper with a number written on it.
It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.
The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.
For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination’s 43. The combination of 12, 34, and 6 is not valid either, because 52 (= 12 + 34 + 6) is greater than the target number of 50.

There are also three special rules:

If the target number is the same as the number on the sheet of paper, then the paper is not cut. For example, if the target number is 100 and the number on the sheet of paper is also 100, then the paper is not cut.
If it not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.
If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed.
In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shedder should “cut up” the second number.

Input
The input consists of several test cases, each on one line, as follows:

t1 num1
t2 num2

tn numn
0 0

Each test case consists of the following two positive integers, which are separated by one space: (1) the first integer (ti above) is the target number; (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that bother integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output
For each test case in the input, the corresponding output takes one of the following three types:

sum part1 part2 …
rejected
error
In the first type, partj and sum have the following meaning:

Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.
sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 + …
Each number should be separated by one space.

The message error is printed if it is not possible to make any combination, and rejected if there is more than one possible combination.

No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.

Sample Input
50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output
43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1539

题意

给一个数字n和一个字符串,用切割字符串使得切割后的数字之和等于n或者尽量接近n,如果无解输出error,有多个解输出rejected,有答案则要把切割的结果输出来。

题解

用mark数组来记录是否要在当前数字的前面增加空格,用dfs来枚举每一位数字前是否添加空格即可。由于最终要输出解,所以用Mark数组来记录最终解的切割状态。用flag标记是否有多个ans,当ans=0时便是无解。
注意:为了方便计算和读入,将字符数组用int a[maxn]来存储。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <stack>
#include <queue>
#include <vector>
#define INF 0xffffffff
using namespace std;

const int maxn = 30;
int n, len;
char str[maxn];
int a[maxn];
int mark[maxn], Mark[maxn];
int flag, ans;

void dfs(int pos, int sum, int num){
    if(sum + num > n) return;
    if(len == pos){
        sum += num;
        if(sum<=n && sum>ans){
            flag = 0;
            ans = sum;
            for(int i=0; i<len; i++){
                Mark[i] = mark[i];
            }
            return;
        }
        if(sum == ans){
            flag = 1;
            return;
        }
        return;
    }
    dfs(pos+1, sum, num*10+a[pos]);
    mark[pos] = 1;
    dfs(pos+1, sum+num, a[pos]);
    mark[pos] = 0;
}

int main(){
    while(scanf("%d%s", &n, str) == 2 && (str[0]-'0')){
        len = strlen(str);
        for(int i=0; i<len; i++){
            a[i] = str[i]-'0';
        }
        flag = 0;
        ans = 0;
        memset(mark, 0, sizeof(mark));
        dfs(1, 0, a[0]);
        if(!ans){
            printf("error\n");
            continue;
        }
        if(flag){
            printf("rejected\n");
            continue;
        }
        printf("%d ", ans);
        for(int i=0; i<len; i++){
            if(Mark[i])
                printf(" ");
            printf("%d", a[i]);
        }
        printf("\n");
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值