POJ 2155(二维树状数组)

Language:
Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 29131 Accepted: 10630

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
题意:给你一个n*n的矩阵,初始值为0,现在有两种操作,’C‘ 翻转给定矩阵的元素(0变为1,1变为0),’Q‘ 查询某个点的值。
分析:难点是修改矩阵内的值,其实只要修改(x1,y1),(x1,y2+1),(x2+1,y2+1),(x2+1,y1);这四点值即可。
对于某一块来说,假如翻转了偶数次,就相当与没有改变,所以只需要知道某点翻转的总次数sum,答案就是sum%2了。树状数组里
得出的其实就是翻转总次数。
可以结合这位大佬的图来理解:http://blog.csdn.net/zxy_snow/article/details/6264135
代码:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=1005;
int tree[maxn][maxn];
int n;
int lowbit(int x)
{
    return x&-x;
}
void add(int pos1,int pos2)
{
    for(int i=pos1;i<=n;i+=lowbit(i))
    {
        for(int j=pos2;j<=n;j+=lowbit(j))
        {
            tree[i][j]++;
        }
    }
}
int GetSum(int pos1,int pos2)
{
    int ans=0;
    for(int i=pos1;i>0;i-=lowbit(i))
    {
        for(int j=pos2;j>0;j-=lowbit(j))
        {
            ans+=tree[i][j];
        }
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(tree,0,sizeof(tree));
        int q;
        scanf("%d%d",&n,&q);
        while(q--)
        {
            char s[10];
            scanf("%s",s);
            if(s[0]=='C')
            {
                int x1,y1,x2,y2;
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                add(x1,y1);
                add(x1,y2+1);
                add(x2+1,y2+1);
                add(x2+1,y1);
            }
            if(s[0]=='Q')
            {
                int x,y;
                scanf("%d%d",&x,&y);
                printf("%d\n",GetSum(x,y)%2);
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

童话ing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值