POJ3069(简单贪心)

Saruman's Army

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17143 Accepted: 8466

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006


 题解:用set存取数据,从小到大遍历然,新的值与l的点距离是否小于r小于就更新p中心点的位置,与p的距离差大于r就ans++;

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
#include<set>
#include<queue>
using namespace std;
#define clr(a,b) memset(a,b,sizeof(a))
#define inf      0x3f3f3f3f3f3f
const int maxn=1000+10;
int lim,n,l[maxn],r[maxn];
set<int> trap;
int main()
{
    while(cin>>lim>>n)
    {
        clr(l,0);trap.clear();
        if(lim==-1&&n==-1){break;}
        int tm;
        for(int i=1;i<=n;++i)
        {
            cin>>tm;
            trap.insert(tm);
        }
        set<int>::iterator it=trap.begin();
        int ans=1;
        l[ans]=r[ans]=*it;
        for(;it!=trap.end();++it)
        {
            if(*it-l[ans]>lim&&*it-r[ans]>lim)
            {
                    l[++ans]=*it;
                    r[ans]=*it;
            }
            else if(*it-l[ans]<=lim){
                r[ans]=*it;
            }
        }
        cout<<ans<<endl;
    }

    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值