PAT-A-1086. Tree Traversals Again (25)

1086. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
#include<iostream>
#include<stack>
#include<cstdio>
#include<string.h>

using namespace std;

const int maxn = 50;
struct node{
  int date;
  node *lchild;
  node *rchild;
};

int pre[maxn];
int in[maxn];
int n;


node *create(int prel, int prer, int inl, int inr)
{

  if (prel > prer)
    return NULL;

  node *root = new node;
  root->date = pre[prel];

  int k;
  for (k = inl; k <= inr; k++)
  {
    if (in[k] == pre[prel])
      break;
  }
  int len = k - inl;
  root->lchild = create(prel + 1, prel + len, inl, k - 1);
  root->rchild = create(prel + len + 1, prer, k + 1, inr);

  return root;

}

int num = 0;
void postorder(node *root)
{
  if (root == NULL)
    return;

  postorder(root->lchild);
  postorder(root->rchild);
  cout << root->date;

  num++;
  if (num < n)
  {
    cout << " ";
  }

}

int main()
{
  cin >> n;
  char s[5];
  stack<int> st;
  int num1 = 0;
  int num2 = 0;
  int d;
  for (int i = 0; i < 2 * n; i++)
  {
    cin >> s;
    if (strcmp(s, "Push")==0)
    {
      cin >> d;
      st.push(d);
      pre[num1++] = d;
    }
    else
    {
      in[num2++] = st.top();
      st.pop();
    }

  }

  node *root = create(0, n - 1, 0, n - 1);
  postorder(root);

  system("pause");
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值