POJ2406--Power Strings(KMP变形)

26 篇文章 0 订阅

Do more with less

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意

字符串abcd 是 abcd 的一次方
字符串aaaa 是 a 的四次方
字符串ababab 是 ab 的3次次方
输入 . 表示测试结束

思路

如果是一个没有重复的串,那它的next数组会一直是0
如果next数组从第二个数起一直增加,说明这个序列是由一个字母组成
如果倒序检索next数组,遇到的第一个0的时候,前面的序列一定不能用次方的形式表示

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char p[1000005];
int nextp[1000005];
int m;
int getnextp()
{
    int i = 0;
    int j = -1;
    nextp[0] = -1;
    while(i <= m)
    {
        if(p[i] == p[j] || j == -1)
        {
            j++;
            i++;
            nextp[i] = j;
        }
        else 
        {
            j = nextp[j];
        }
    }
    i = m;
    while(nextp[i] > nextp[i-1] && i >= 0)
    {
        i--;
    }
    if(i == 0)
        return m;
    if(nextp[i] == 0 && m % i == 0)
        return m /i;
    else
        return 1;
}
int main()
{
    while(scanf("%s",p) && p[0] != '.')
    {
        m = strlen(p);
        printf("%d\n", getnextp());
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值