poj 2406 Power Strings next[]


                                                                                               Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 39125 Accepted: 16238

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source




#include<cstring>
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
const int maxm=1000000+20;
int nex[maxm];
char M[maxm];
int m;
void getnex()
{
    int j=nex[1]=0;
	for(int i=1;i<=m; )
	{
		while(j&&M[i]!=M[j])  j=nex[j];
		nex[++i]=++j;
	}

}
int main()
{
   while(~scanf("%s",M+1)&&strcmp(M+1,".")!=0)
   {
	   m=strlen(M+1);
	   getnex();
	   int circle=m+1-nex[m+1];
	   int ans=m%circle?1:m/circle  ;
	   printf("%d\n",ans);
	   


   }
 

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值