Power Strings
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 45249 | Accepted: 18883 |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
#include<stdio.h>
#include<string.h>
#define maxn 1000100
int next[maxn];
char s[maxn];
void get_next(char *s)
{
int len1=strlen(s);
int i=0,j=-1;
next[0]=-1;
while(i<len1)
{
if(j==-1||s[i]==s[j])
{
next[++i]=++j;
}
else j=next[j];
}
}
int main()
{
int len,i,j;
while(~scanf("%s",s)&&s[0]!='.')
{
len=strlen(s);
get_next(s);
if(len%(len-next[len])==0)
printf("%d\n",len/(len-next[len]));
else
printf("1\n");
}
return 0;
}