POJ 2406 Power Strings(kmp)

Language:
Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 33335 Accepted: 13852

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source



求一个串的最小周期


对于一个串,如果abcdabc 那么next[len]=3,那么len-next【len】就大于len/2,那么len%(len-next[len])!=0;而对于一个周期串ababab next[len]=4,此时len-next[len]应该等于

最小串的长度,所以是不是有最小周期就可以用len%(len-next[len])是否为0来判断,(个人理解,如有错,请想告)



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
using namespace std;
#define N 100005

char a[N];
int len,next[N];

void getfail(char *a)
{
	 int i,j;
	 len=strlen(a);
	 i=0;j=-1;
	 next[0]=-1;
	 while(i<len)
	 {
	 	if(j==-1||a[i]==a[j])
		{
			 i++;
			 j++;
			 next[i]=j;
		}
		else
			j=next[j];
	 }
}

int main()
{
	int i,j;
	while(scanf("%s",a))
	{
		if(a[0]=='.') break;
		getfail(a);
		int ans=len%(len-next[len]);
		if(ans==0)
			printf("%d\n",len/(len-next[len]));
		else
			printf("1\n");
	}
	return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值