2018.07.06 POJ1273 Drainage Ditches(最大流)

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50
Source
USACO 93

一道最大流的板子题,感觉也没什么好说的,建图也比较 easy e a s y ,直接套个 dinic d i n i c 就行了。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define oo 0x3f3f3f3f
#define N 10005
using namespace std;
struct Node{
    int v,next,c;
}e[N<<1];
int tot=1,n,m,d[N],first[N];
inline void add(int u,int v,int c){
    e[++tot].v=v;
    e[tot].next=first[u];
    e[tot].c=c;
    first[u]=tot;
}
inline long long read(){
    long long ans=0;
    char ch=getchar();
    while(!isdigit(ch))ch=getchar();
    while(isdigit(ch)){
        ans=(ans<<3)+(ans<<1)+ch-'0';
        ch=getchar();
    }
    return ans;
}
inline int max(int a,int b){return a>b?a:b;}
inline bool bfs(){
    queue<int>q;
    q.push(1);
    memset(d,-1,sizeof(d));
    d[1]=0;
    while(!q.empty()){
        int x=q.front();
        q.pop();
        for(int i=first[x];i!=-1;i=e[i].next){
            if(d[e[i].v]==-1&&e[i].c){
                d[e[i].v]=d[x]+1;
                if(e[i].v==m)return true;
                q.push(e[i].v);
            }

        }
    }
    return false;
}
inline int dfs(int p,int f){
    if(p==m)return f;
    int cnt=f;
    for(int i=first[p];i!=-1;i=e[i].next){
        int v=e[i].v;
        if(d[v]==d[p]+1&&e[i].c>0&&cnt){
            int maxn=dfs(v,min(cnt,e[i].c));
            if(maxn==0)d[v]=-1;
            cnt-=maxn;
            e[i].c-=maxn;
            e[i^1].c+=maxn;
        }

    }
    return f-cnt;
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        tot=1;
        memset(first,-1,sizeof(first));
        for(int i=1;i<=n;++i){
            int u=read(),v=read(),w=read();
            add(u,v,w);
            add(v,u,0);
        }
        int ans=0;
        while(bfs())ans+=dfs(1,oo);
        printf("%d\n",ans);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值