E - The shortest problem

In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
InputMultiple input. 
We have two integer n (0<=n<= 104104 ) , t(0<=t<= 105105) in each row. 
When n==-1 and t==-1 mean the end of input. 
OutputFor each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.Sample Input
35 2
35 1
-1 -1
Sample Output
Case #1: Yes

Case #2: No

这题如果我们直接用大数除法的话是肯定超时的,所以我们要在对字符串进行操作的时候就把它与11的余数算出来

#include <bits/stdc++.h>

using namespace std;

const int inf = 1e6 + 10;
int main()
{
    int  n, t;
    int N = 0;
    while(scanf("%d %d", &n, &t) != EOF && (t != -1 || n != -1)){
       N ++;
       int he = 0;
       int yu = n % 11;
       while(n){
          he += n % 10;
          n /= 10;
       }
       int he2 = 0, he3 = 0;
       int wei;
       for(int i = 0; i < t; i ++){
            wei = 1;
            he3 = he;
            he2 = he;
            while(he2){
                wei *= 10;
                he += he2 % 10;//he是下次要添加的数
                he2 /= 10;
            }
            yu = yu * wei + he3;//这里别用yu * pow(10,he2的位数),因为pow返回的类型是double,很可能会出错
            yu %= 11;
       }
       if(yu) printf("Case #%d: No\n", N);
       else printf("Case #%d: Yes\n", N);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
All-Pairs Shortest Path问题是指在一个带权有向图中,求出任意两个节点之间的最短路径。解决这个问题的算法称为All-Pairs Shortest Path算法。 常用的All-Pairs Shortest Path算法有Floyd-Warshall算法和Johnson算法。 Floyd-Warshall算法的基本思想是动态规划。用dist[i][j]表示从节点i到节点j的最短路径长度,用k表示中间节点,则有状态转移方程: ``` dist[i][j] = min(dist[i][j], dist[i][k] + dist[k][j]) ``` 其中,dist[i][j]的初始值为节点i到节点j的边权,如果i和j之间没有边,则为正无穷。算法的核心是对k从1到n的循环,依次更新dist[i][j]的值,最终得到所有节点之间的最短路径长度。 Floyd-Warshall算法的时间复杂度为O(n^3),其中n为节点数,主要时间花费在三层循环上,实际应用中可以通过空间换时间的方式优化算法。 Johnson算法的基本思想是通过引入一个虚拟节点,并将其与所有节点之间的边权设为0,将问题转化为带权有向图中的单源最短路径问题。然后使用Bellman-Ford算法求出虚拟节点到其它所有节点的最短路径长度,再用求最短路径时的松弛操作更新所有边的边权,将问题转化为带权有向图中的多源最短路径问题。最后使用Dijkstra算法求出所有节点之间的最短路径长度。 Johnson算法的时间复杂度为O(n^2logn+m),其中n为节点数,m为边数,主要时间花费在Bellman-Ford算法和Dijkstra算法上,实际应用中可以通过优化数据结构等方式优化算法。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值