hdu 3306 Another kind of Fibonacci(矩阵快速幂)

Another kind of Fibonacci

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2643 Accepted Submission(s): 1055

Problem Description
As we all known , the Fibonacci series : F(0) = 1, F(1) = 1, F(N) = F(N - 1) + F(N - 2) (N >= 2).Now we define another kind of Fibonacci : A(0) = 1 , A(1) = 1 , A(N) = X * A(N - 1) + Y * A(N - 2) (N >= 2).And we want to Calculate S(N) , S(N) = A(0)2 +A(1)2+……+A(n)2.

Input
There are several test cases.
Each test case will contain three integers , N, X , Y .
N : 2<= N <= 231 – 1
X : 2<= X <= 231– 1
Y : 2<= Y <= 231 – 1

Output
For each test case , output the answer of S(n).If the answer is too big , divide it by 10007 and give me the reminder.

Sample Input
2 1 1
3 2 3

Sample Output
6
196

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<queue>
#include<math.h>
#include<vector>
#include<iostream>
using namespace std;
typedef long long ll;
const int mod=10007;
ll n,x,y;
struct node
{
    ll a[4][4];
    node()
    {
        memset(a,0,sizeof(a));
    }
}A,B;
node operator *(node a,node b)
{
    node ans;
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
            for(int k=0;k<4;k++)
                ans.a[i][j]=((ans.a[i][j]+a.a[i][k]*b.a[k][j])%mod+mod)%mod;
    return ans;
}
void aa(ll x)
{
    node ans=A,p=B;
    while(x)
    {
        if(x&1)
            ans=ans*p;
        p=p*p;
        x=x/2;
    }
    ll  o=(ans.a[0][3]%mod+mod)%mod;
    cout<<o<<endl;
}
int main()
{

   A.a[0][0]=1,A.a[0][1]=1,A.a[0][2]=1,A.a[0][3]=1;
  while(~scanf("%lld%lld%lld",&n,&x,&y))
  {
      x%=mod;
      y%=mod;
      B.a[0][0]=(x*x)%mod,B.a[0][1]=1,B.a[0][2]=x,B.a[0][3]=1;
      B.a[1][0]=(y*y)%mod,B.a[1][1]=0,B.a[1][2]=0,B.a[1][3]=0;
      B.a[2][0]=(2*x*y)%mod,B.a[2][1]=0,B.a[2][2]=y,B.a[2][3]=0;
      B.a[3][0]=0,B.a[3][1]=0,B.a[3][2]=0,B.a[3][3]=1;
      aa(n);
  }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值