Domination ZOJ - 3822 (概率dp 求期望)

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

题意 :有 n*m 的棋盘 ,求棋盘的每一行 每一列 上都有棋子的  放旗子的 期望

设 dp[ i ] [ j ] [ k ]  代表这个状态到终点状态的期望  i 代表已经放了 i 个 棋子  j 代表 有 j行 已经有棋子  k 代表 有 k 列有棋子

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
double dp[2][55][55];
int main()
{
    int t,n,m;
    double p1,p2,p3,p4;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        int cnt=1;
        for(int i=n*m-1;i>=0;i--)
        {
            cnt^=1;
            memset(dp[cnt],0,sizeof(dp[cnt]));
            for(int j=n;j>=0;j--)
            {
                for(int k=m;k>=0;k--)
                {
                    if(j==n&&k==m) continue;//已经到达终点状态
                    if(i<max(j,k)) continue;//不存在这种状态
                    if(i>j*k) continue;//不存在这种状态
                    p1=1.0*(j*k-i)/(n*m-i);//要 -i 是因为之前i个棋子都在 j*k的方格里 不能重复放
                    p2=1.0*(n-j)*k/(n*m-i);
                    p3=1.0*(m-k)*j/(n*m-i);
                    p4=1.0*(n-j)*(m-k)/(n*m-i);
                    dp[cnt][j][k]+=p1*dp[cnt^1][j][k];
                    dp[cnt][j][k]+=p2*dp[cnt^1][j+1][k];
                    dp[cnt][j][k]+=p3*dp[cnt^1][j][k+1];
                    dp[cnt][j][k]+=p4*dp[cnt^1][j+1][k+1];
                    dp[cnt][j][k]+=1;//加一 因为i 的状态到 i+1的状态需要1步
                }
            }
        }
        printf("%.8lf\n",dp[cnt][0][0]);
    }
}
 
 
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值