hdu 2717 Catch That Cow (BFS)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12344    Accepted Submission(s): 3833


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source

题意:人抓牛,牛的位置为k,人的位置为n,人又三种走法:前进一步、后退一步、或者直接到是自己位置坐标二倍的地方,即2*n,三种走法都各花费一分钟,求人抓到牛花费的最少时间。-----BFS-----


<span style="font-family:SimSun;font-size:18px;">#include<stdio.h>
#include<queue>
#include<functional>
#include<string.h>
using namespace std;
int n,k,nk,vis[100010];
int d[3]={2,1,-1};  //人的三种走法 
struct node
{
	int x;
	int time;
	friend bool operator < (node a,node b) //时间小的先出队 
	{
		return a.time > b.time;
	}
};
int bfs(int t)
{
	priority_queue<node>que;
	node st,ed;
	st.x=t;
	st.time=0;
	que.push(st);
	while(!que.empty())
	{
		st=que.top();
		que.pop();
		if(st.x==k)
			return st.time;
		for(int i=0;i<3;i++)
		{
			if(i==0)
				ed.x=st.x*d[i];
			else
				ed.x=st.x+d[i];
			if(ed.x>=100010||ed.x<0) //一定要判断 不然会出错 
				continue;
			if(!vis[ed.x])
			{
				vis[ed.x]=1;       //标记已走过的路线,以后不再走 
				ed.time=st.time+1;
				que.push(ed);
			}
		}
	}
	return 0;
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		if(n>=k)
		{
			printf("%d\n",n-k);   //要先判断,n 若大于 k 只能一步一步往回走 
		}
		else
		{
			nk=k-n;
			memset(vis,0,sizeof(vis));
			vis[n]=1;
			int ans=bfs(n);
			printf("%d\n",ans);
		}
	}
}</span>


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值