RGCDQ(筛法)

Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know maxGCD(F(i),F(j))  (Li<jR) 

Input

There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000

Output

For each query,output the answer in a single line.
See the sample for more details.

Sample Input

2
2 3
3 5

Sample Output

1
1

思路:利用筛法的特性求出2到一百万的每个数本身有几类素因子组成。然后,因为最多种类不会超过7,(2*3*5*7*11*13*17*19超过了
1000000),所以进行判断。另外,这道题用c++输入输出会超时。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<iostream>
using namespace std;

typedef long long LL;
const int N=1000000;
bool a[N+10];
int b[N+10];
int s[N+10][8];
int t[8];
int main()
{
    int T;
    cin>>T;
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    for(int i=2; i<=N; i++)
    {
        if(!a[i])
            for(int j=i; j<=N; j+=i)
            {
                a[j]=1;
                b[j]++;
            }
        for(int j=1; j<=7; j++)
            s[i][j]=s[i-1][j];
        s[i][b[i]]++;
    }
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int p=1;
        for(int i=1; i<=7; i++)
        {
            t[i]=s[m][i]-s[n-1][i];
            if(t[i]>=2)
                p=max(i,p);
            if((t[2]&&t[4])||(t[4]&&t[6])||(t[2]&&t[6]))
                p=max(p,2);
        }
        printf("%d\n",p);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值