PAT-A-1155.Heap Paths(30) C/C++实现(完全二叉树,递归,DFS)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure)
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50

Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:
8
8 38 25 58 52 82 70 60

Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:
8
10 28 15 12 34 9 8 56

Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

  • 题目大意:
    首先给出堆的概念:堆是一棵特殊的树,如果是大顶堆,则满足所有父亲节点的值都不小于他的孩子节点的值;如果是小顶堆,则所有父亲节点的值,都不大于他的孩子节点的值;
    现在题目给出一棵完全二叉树的层序遍历结果,需要解决两个需求:

    1. 按照从右到左的顺序,依次打印出从根节点到叶子节点的所有路径;
    2. 判断这棵完全二叉树是否为一个堆,如果是,进一步判断他是大顶堆还是小顶堆;
  • 思路:

    1. 将题目给出的完全二叉树的层序遍历结果读入下标为0 ~ n - 1的数组num,对于任意一个节点num[i], 他的左子节点是num[(i * 2 + 1],右子节点是num[(i * 2 + 2];
    2. 如果一个节点的左子节点的下标 >= n,则此节点没有孩子节点(因为是完全二叉树,只需判断左子节点即可);用这个方法可以判断一个节点是否为叶子节点;
    3. 递归方法构建一个函数Findroute,用来寻找并打印从根节点到叶子节点的路径;
    4. 在打印的过程中进行判断,如果父亲节点大于孩子节点,ismax = true;如果父亲节点小于孩子节点,ismin = true;最后,如果ismax 和 ismin 都是ture,则不是堆;
#include <iostream>
#include <vector>
using namespace std;
vector <int> route; //用来记录路径
int num[1000];
int n;
bool ismin = false, ismax = false;
void Findroute(int rootindex)
{
    route.push_back(num[rootindex]);
    if (2 * rootindex + 2 < n)
    {
        Findroute(2 * rootindex + 2);//先寻找右子树中的路径
    }
    if (2 * rootindex + 1 < n)
    {
        Findroute(2 * rootindex + 1); //再寻找左子树中的路径
    }
    if (2 * rootindex + 1 >= n) //如果当前节点为叶子节点,则输出路径
    {
        for (int i = 0; i < route.size(); i++)
        {
            printf("%d%c", route[i], i < route.size() - 1 ? ' ' : '\n');
            ismax = (i < route.size() - 1 && route[i] > route[i + 1]) ? true : ismax;
            ismin = (i < route.size() - 1 && route[i] < route[i + 1]) ? true : ismin;
        }
    }
    route.pop_back(); 
}
int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> num[i];
    }
    Findroute(0);
    if (ismax && ismin)
    {
        cout << "Not Heap";
    }
    else if (ismax)
    {
        cout << "Max Heap";
    }
    else 
    {
        cout << "Min Heap";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值