题目
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.
Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
题目大意
给出一颗完全二叉树,要求按照从从父母>孩子节点>孙子……这样的顺序输出,输出顺序是右孩子先,左孩子后。
然后判断是否是一个堆。
直觉
是一道排列组合题,所以想到用dfs解决,关键是如何按照题目要求的顺序遍历。
加入二叉树从根节点开始标号为1,左孩子的序号总是它的两倍。所以按照这个可以写出遍历。
复杂度分析
有一个dfs递归,复杂度为O(N²)
代码
#include<iostream>
#include<vector>
using namespace std;
int total;
int tree[1010];
vector<int> path;
bool vis[1010]={0};
void dfs(int n){
if(n*2>total&&n*2+1>total){
if(n<=total){
for(int i=0;i<path.size();++i){
cout<<path[i];
if(i<path.size()-1)cout<<" ";
}
cout<<endl;
}
}else{
path.push_back(tree[n*2+1]);
dfs(n*2+1);
path.pop_back();
path.push_back(tree[n*2]);
dfs(n*2);
path.pop_back();
}
}
int main(){
cin>>total;
for(int i=1;i<=total;++i){
cin>>tree[i];
}
path.push_back(tree[1]);
dfs(1);
int isMin=1,isMax=1;
for (int i = 2; i <= total; i++) {
if (tree[i/2] > tree[i]) isMin = 0;
if (tree[i/2] < tree[i]) isMax = 0;
}
if(isMax==0&&isMin==0){
cout<<"Not Heap";
}
else if(isMax==1) {
cout<<"Max Heap";
}
else{
cout<<"Min Heap";
}
return 0;
}
提交时间 状态 分数 题目 编译器 耗时 用户
2019/8/25 21:13:50
答案正确
30 1155 C++ (g++) 5 ms Chester
测试点 结果 耗时 内存
0 答案正确 4 ms 356 KB
1 答案正确 4 ms 356 KB
2 答案正确 4 ms 356 KB
3 答案正确 4 ms 384 KB
4 答案正确 4 ms 368 KB
5 答案正确 3 ms 424 KB
6 答案正确 5 ms 356 KB