PAT-A-1006 Sign In and Sign Out (25分) C/C++实现(字符串处理)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133

  • 题目大意:
    这是一个非常简单的字符串处理题,给出每个人的id,进入教室的时间和走出教室的时间,找出第一个进教室的人和最后一个出教室的人;
  • 思路:
    1. c++中string重载了运算符,将时间作为字符串读入,可以直接用>, <, == 来进行比较;
#include <iostream>
#include <string>
using namespace std;
int main()
{
    int m;
    string unlock_id, lock_id, unlock_time = "23:59:59", lock_time = "00:00:00";
    cin >> m;
    while (m-- > 0)
    {
        string id, in_time, out_time;
        cin >> id >> in_time >> out_time;
        if (in_time < unlock_time)
        {
            unlock_time = in_time;
            unlock_id = id;
        }
        if (out_time > lock_time)
        {
            lock_time = out_time;
            lock_id = id;
        }
    }
    cout << unlock_id << ' ' << lock_id;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值