hdoj 4135 Co-prime

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3004    Accepted Submission(s): 1164


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source 
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1796  1434  3460  1502  4136 
 

Statistic |  Submit |  Discuss |  Note




思路:

         之前做的一道题是给定的几个数,让你找出四个数互质的数的组数,那个需要将所有的数的质因数都找出来,并且统计那个质因数是输入的几个数中的几个数的质因数,然后用总共的输入的数中的四个数的组数减去有相同公约数的四个数的组数,就是没有除1之外的数的公约数的组数!
         而这道题是给定你一个数n已经确定,并且给你了一个区间,然你找在这个区间内有多少个数与n互质!因此你也可以用这种逆向思维,先找不互质的数,然后用总数减去不互质的数的个数,得出的就是互质的数的个数!
         这里面我们还有一个公式需要知道,那就是区间[a,b](a>0)的情况下能被k整除的数的个数,有num=b/k-(a-1)/k;
         同理,我们这里面不是找整除的数的,而是找与n互质的数的,所以我们可以找1到b中与n互质的数减去1到a-1中与n互质的数就是我们的所求!

代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define LL long long
using namespace std;
int prime[10]={0};//1-10^9的范围内质因数不超过10
int k; 
int que[1025];
void solve(LL n)
{
	k=0;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)
			prime[k++]=i;
		while(n%i==0)
			n/=i;
	}
	if(n>1) prime[k++]=n;
}
LL nop(LL n)
{
	LL top=0;
	que[top++]=-1;
	for(LL i=0;i<k;i++)
	{
		LL t=top;
		for(LL j=0;j<t;j++)
		{
			que[top++]=que[j]*prime[i]*(-1);
		}
	}
	LL sum=0;
	for(LL i=1;i<top;i++)//因为-1不是正因数,所以应该从1开始找 
	{//1到n中有多少个数有质因子que[i]! 
		sum+=n/que[i];
	}
	return sum;
}
int main()
{
	int T;
	scanf("%d",&T);
	for(int i=1;i<=T;i++)
	{
		LL a,b,n;
		scanf("%lld%lld%lld",&a,&b,&n);
		solve(n);
		printf("Case #%d: %lld\n",i,b-nop(b)-(a-1-nop(a-1)));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值