[HDU5573]Binary Tree

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)

分数:2500,构造还是比较难的

Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say f r o o t = 1 f_{root}=1 froot=1.
And for each node u, labels as fu, the left child is f u × 2 f_{u×2} fu×2 and right child is f u × 2 + 1 f_{u×2+1} fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is f x f_x fx (remember f r o o t = 1 f_{root}=1 froot=1), he can choose to increase his number of soul gem by fx, or decrease it by f x f_x fx.

He will walk from the root, visit exactly K K K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N N N, then he will succeed.
Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.
Given N , K N, K N,K, help the King find a way to collect exactly N N N soul gems by visiting exactly K K K nodes.

Input
First line contains an integer T T T, which indicates the number of test cases.
Every test case contains two integers N N N and K K K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

1 ≤ T ≤ 100 1≤T≤100 1T100
1 ≤ N ≤ 1 0 9 1≤N≤10^9 1N109
N ≤ 2 K ≤ 2 60 N≤2^K≤2^{60} N2K260

Output
For every test case, you should output “Case #x:” first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as ‘a b’, where a is node label of the node the frog visited, and b is either ‘+’ or ‘-’ which means he increases / decreases his number by a.

It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input

2
5 3
10 4

Sample Output

Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +

题意:
给定 n , k n,k n,k
刚开始你位于二叉树的1号节点,编号x的两个儿子分别是 x × 2 x×2 x×2 x × 2 + 1 x×2+1 x×2+1,每次你可以选择增加等于这个节点编号的灵魂石,或者减少这个节点编号的灵魂石,要求最后到达第 k k k层的时候,得到的灵魂石的个数恰好为 n n n

题解:
我们想想一直走 1 , 2 , 4 , . . . , 2 k − 1 1,2,4,...,2^{k-1} 1,2,4,...,2k1这种方法
考虑 n n n为偶数的时候。设 y = 2 k − 1 − n y = 2^k-1-n y=2k1n我们显然可以根据 y y y的二进制从低到高来考虑,如果第k+1位是0则我们加上第k层,否则减去第k层。
然后对于n为奇数的情况。我们只要把n变为n-1之后,就可以直接按照奇数的做了,但是最后一层要加上 2 k − 1 + 1 2^{k-1}+1 2k1+1

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int k;
ll n;
int w33ha(int CASE){
    scanf("%lld%d",&n,&k);
    printf("Case #%d:\n",CASE);
    ll res=(1LL<<k)-1-n;
    ll flag=0;
    if(res&1){
        res++;
        flag=1;
    }
    for(int i=0;i<k-1;i++){
        if(res&(1LL<<(i+1))){
            printf("%lld -\n",(1LL<<i));
        }
        else{
            printf("%lld +\n",(1LL<<i));
        }
    }
    printf("%lld +\n",(1LL<<(k-1))+flag);
    return 0;
}
int main(){
    int T;scanf("%d",&T);
    for(int i=1;i<=T;i++)w33ha(i);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值