[POJ3259]Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意理解(PS:题解):就是找图中有没有负权环,普通道路是建双向边,虫洞是建单向边,权值是 -T 。

#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#define LiangJiaJun main
#define MOD 10000007
using namespace std;
stack<int>q;
int n,m,w;
struct edge{
    int to,next,w;
}e[250004];
int ne=1,h[1004],F,dis[1004],cnt[1004];
bool inq[1004];
void insert(int u,int v,int w){
     e[++ne].to=v;
     e[ne].next=h[u];
     e[ne].w=w;
     h[u]=ne;
}
void RESET(){
     memset(inq,0,sizeof(inq));
     memset(h,0,sizeof(h));
     memset(cnt,0,sizeof(cnt));
     ne=1;
}
bool spfa(int ask){
     q.push(ask);
     memset(dis,127/3,sizeof(dis));
     dis[ask]=0;inq[ask]=1;
     while(!q.empty()){
        int x=q.top();q.pop();
        cnt[x]++;
        if(cnt[x]>=n)return 1;
        for(int i=h[x];i;i=e[i].next){
            if(dis[e[i].to]>dis[x]+e[i].w){
               dis[e[i].to]=dis[x]+e[i].w;
               if(!inq[e[i].to]){
                   inq[e[i].to]=1;
                   q.push(e[i].to);
               }
            }
        }
        inq[x]=0;
     }
     return 0;
}
void WORK(){
     RESET();
     scanf("%d%d%d",&n,&m,&w);
     for(int i=1;i<=m;i++){
         int u,v,w;
         scanf("%d%d%d",&u,&v,&w);
         insert(u,v,w);insert(v,u,w);
     }
     for(int i=1;i<=w;i++){
        int u,v,w;
        scanf("%d%d%d",&u,&v,&w);
        insert(u,v,-w);
     }
     if(spfa(1))puts("YES");
     else puts("NO");
}
int LiangJiaJun(){
    scanf("%d",&F);
    while(F--)WORK();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值