1030. Travel Plan (30)

原题地址:http://www.patest.cn/contests/pat-a-practise/1030

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

解题思路:dfs回溯即可。

代码如下:

#include <stdio.h>
#include <algorithm>
#include <cstring>
#include <vector>
#define INF 10000000;
using namespace std;

int G[505][505];
int C[505][505];
int vis[505];
int N,M,S,D;

int minDist;
int minCost;
int dist;
int cost;
vector<int> route;
vector<int> tmp;

void dfs_m(int s){
    vis[s] = 1;
    tmp.push_back(s);
    for(int i = 0; i < N; i++){
        if(!vis[i] && G[s][i]){
            dist += G[s][i];
            cost += C[s][i];
            if(dist > minDist){
                dist -= G[s][i];
                cost -= C[s][i];
                continue;
            }
            if(i == D){
                tmp.push_back(i);
                if(dist < minDist){
                    minDist = dist;
                    minCost = cost;
                    route.clear();
                    route.assign(tmp.begin(),tmp.end());
                }else if(dist == minDist){
                    if(cost < minCost){
                        minCost = cost;
                        route.clear();
                        route.assign(tmp.begin(),tmp.end());
                    }
                }

                tmp.pop_back();
                dist -= G[s][i];
                cost -= C[s][i];
                continue;
            }
            dfs_m(i);
            dist -= G[s][i];
            cost -= C[s][i];
        }
    }
    tmp.pop_back();
    vis[s] = 0;
}

int main(){
    freopen("1030.txt","r",stdin);
    scanf("%d%d%d%d",&N,&M,&S,&D);
    memset(G,0,sizeof(G));
    memset(C,0,sizeof(C));
    for(int i = 0;i < M; i++){
        int f,t,d,c;
        scanf("%d%d%d%d",&f,&t,&d,&c);
        G[f][t] = G[t][f] = d;
        C[f][t] = C[t][f] = c;
//      printf("%d-%d: %d : %d\n", f,t,G[f][t],C[f][t]);
    }
    memset(vis,0,sizeof(vis));
    dist = 0;
    cost = 0;
    minDist = INF;
    minCost = INF;
    dfs_m(S);
    for(int i = 0; i < route.size();i++)
        printf("%d ",route[i]);
    printf("%d %d",minDist,minCost);
    return 0;
}
travel Algrithm. #include <stdio.h> #include <stdlib.h> #include <string.h> #include <malloc.h> #include <conio.h> struct Path { char pass[25]; //sign passed note. int min_distance; //minmax distance from concurrent note.// int nextcity; //next note from current note. struct Path *next; }; int C[25][25]; int Getmin(struct Path *G[25][25],int i,int num_S,char S[25]); // search G[i][n] linking-node. void Write(int i,int n,char S[25],struct Path *G[25][25],int num_S); // Calculate G[i][num_S] void Travel(int size,int i,int n,char S[25],struct Path *G[25][25],int num_S); // signed V-S node. void Trip(int n,char S[25],struct Path *G[25][25]); // Calculate and output the min_distance. void Printpath(char S[],int path[],struct Path *G[][25],int n); // print the path // S[] is the charater of the node. void main() { int n,i,j; int output[25]; char S[25]; struct Path *G[25][25]; printf("Please enter the number of cities:\n"); // Input the numbers of node scanf("%d",&n); printf("Please enter the matrix:\n"); // Input the maxtric of weight. for(i=0;i<n;i++) for(j=0;j<n;j++) scanf("%d",&C[i][j]); printf("The number of cities is:%d\n",n); for(i=0;i<n;i++) { for(j=0;j<n;j++) printf("%d\t",C[i][j]); printf("\n"); } for(i=0;i<n;i++) S[i]='0'; S[i]='\0'; for(i=0;i<n;i++) { G[i][0]=(struct Path *)malloc(sizeof(struct Path)); strcpy(G[i][0]->pass,S); G[i][0]->min_distance=C[i][0]; G[i][0]->next=NULL; } for(i=0;i<n;i++) for(j=1;j<n;j++) G[i][j]=NULL; Trip(n,S,G); Printpath(S,output,G,n); printf("For the demonstration route:\n"); for(i=0;i<n;i++) printf("%d->",output[i]+1); printf("1\n"); getch(); }
该信息出现的原因是因为在映射文件中找不到com.travel.travel.mapper.UserMapper.findAll这个绑定的语句。根据引用提供的信息,你需要在Java的配置文件中创建一个包,将你的mapper映射文件放进去,并且要注意包名与你的mapper接口的包名要一致。另外,根据引用提供的信息,你还需要在pom.xml文件中加入一些配置,以确保资源和代码文件被正确加载。最后,根据引用提供的信息,你可以下载一个提供者和消费者模块的示例代码进行学习,并在http://127.0.0.1:8083/user/getUser这个地址上进行简单的调用。这些步骤和配置可以帮助你解决Invalid bound statement (not found)的问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [Invalid bound statement (not found): com.itheima.mapper.userMapper.SelectAll](https://blog.csdn.net/weixin_64773406/article/details/127726908)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [plan_project.zip](https://download.csdn.net/download/weixin_39846786/12233758)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值