HDU4891 The Great Pan

The Great Pan


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 321 Accepted Submission(s): 129


Problem Description
As a programming contest addict, Waybl is always happy to take part in various competitive programming contests. One day, he was competing at a regional contest of Inventing Crappy Problems Contest(ICPC). He tried really hard to solve a "geometry" task without success.

After the contest, he found that the problem statement is ambiguous! He immediately complained to jury. But problem setter, the Great Pan, told him "There are only four possibilities, why don't you just try all of them and get Accepted?".

Waybl was really shocked. It is the first time he learned that enumerating problem statement is as useful as trying to solve some ternary search problem by enumerating a subset of possible angle!

Three years later, while chatting with Ceybl, Waybl was told that some problem "setters" (yeah, other than the Great Pan) could even change the whole problem 30 minutes before the contest end! He was again shocked.

Now, for a given problem statement, Waybl wants to know how many ways there are to understand it.

A problem statement contains only newlines and printable ASCII characters (32 ≤ their ASCII code ≤ 127) except '{', '}', '|' and '$'.

Waybl has already marked all ambiguity in the following two formats:

1.{A|B|C|D|...} indicates this part could be understand as A or B or C or D or ....
2.$blah blah$ indicates this part is printed in proportional fonts, it is impossible to determine how many space characters there are.

Note that A, B, C, D won't be duplicate, but could be empty. (indicate evil problem setters addedclarified it later.)

Also note that N consecutive spaces lead to N+1 different ways of understanding, not 2N ways.

It is impossible to escape from "$$" and "{}" markups even with newlines. There won't be nested markups, i.e. something like "${A|B}$" or "{$A$|B}" or "{{A|B}|C}" is prohibited. All markups will be properly matched.


Input
Input contains several test cases, please process till EOF.
For each test case, the first line contains an integer n, indicating the line count of this statement. Next n lines is the problem statement.
1 ≤ n ≤ 1000, size of the input file will not exceed 1024KB.


Output
For each test case print the number of ways to understand this statement, or "doge" if your answer is more than 105.


Sample Input
9
I'll shoot the magic arrow several
times on the ground, and of course
the arrow will leave some holes
on the ground. When you connect
three holes with three line segments,
you may get a triangle.
{|It is hole! Common sense!|
No Response, Read Problem
Statement|don't you know what a triangle is?}
1
Case $1: = >$
5
$/*This is my code printed in
proportional font, isn't it cool?*/
printf("Definitely it is cooooooool \
%d\n",4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4
* 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4);$
2
$Two space$ and {blue|
red} color!


Sample Output
4
4
doge
6


Source
2014 Multi-University Training Contest 3

题意:说是理解话的方式,有一种是{}形式的,比如{A|B|C|D},就是可以理解成A,或者B或者C或者D一共4,种,还有个是$    $,里面的空格代表可以理解成0或者1,如果里面有两个不相邻的空格,那么答案就是4,相邻空格加1。

这题读懂了题目的意思就很容易了,一个很简单的模拟题,这里有个坑点就是中间乘法一出会超int(比赛时被坑了),所以要用__int64,其他的直接模拟就是了

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1000010];
int n;
int main()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        int dog=0;
        int flag1=0,flag2=0;
        __int64 ans=1,ans1=1,ans2=0;
        while(n--)
        {
            gets(s);
            int len=strlen(s);
            for(i=0;i<len;i++)
            {
                if(flag1==0&&flag2==0&&s[i]=='{')
                {
                    flag1=1;
                    continue;
                }
                if(flag2==0&&flag1==0&&s[i]=='$')
                {
                    flag2=1;
                    continue;
                }
                if(flag1==1)
                {
                    if(s[i]=='|')
                        ans1++;
                    else if(s[i]=='}')
                    {
                        ans*=ans1;
                        ans1=1;
                        flag1=0;
                        if(ans>100000)
                        {
                            dog=1;
                            break;
                        }
                    }
                }
                if(flag2==1)
                {
                    if(s[i]==' ')
                        ans2++;
                    else if(s[i]!='$')
                    {
                        ans*=(ans2+1);
                        ans2=0;
                        if(ans>100000)
                        {
                            dog=1;
                            break;
                        }
                    }
                    else if(s[i]=='$')
                    {
                        flag2=0;
                        ans*=(ans2+1);
                        ans2=0;
                        if(ans>100000)
                        {
                            dog=1;
                            break;
                        }
                    }
                }
            }
        }
        if(dog)
            printf("doge\n");
        else
            printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值