Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.
All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210
大致题意:有编号1~P的站点, 有Q条公交车路线,公交车路线是单向的,每条路线有它自己的车费。
有P个人早上从站点1出发,他们要到达每一个公交站点, 然后到了晚上再返回站点1。 求所有人一天来回的最小费用之和。
思路:跟之前的那道 poj 3268 Silver Cow Party 思路基本差不多,首先计算一遍从站点1到各个站点的最少花费,然后将站点间的花费调换,比如将站点u到v的花费w改成v到u花费w,然后再求一遍站点1到其他站点的最少花费,最后将两次所求得的值全部相加起来即可。
(注意站点和边的数量很大,若用相邻矩阵来存是不行的,这里我们采用链式前向星存储边)
代码如下
/*
采用链式前向星存储边
*/
#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=1000005;
struct node
{
int num;
int dis;
node(int _num=0,int _dis=0):num(_num),dis(_dis){}
friend bool operator <(node a,node b)
{
if(a.dis==b.dis) return a.num>b.num;
return a.dis>b.dis;
}
};
struct Edge
{
int v,cost;
int next;
}edge1[1000005],edge2[1000005];
int tol1,tol2;
int head1[MAXN],head2[MAXN];
int dis1[MAXN],dis2[MAXN];
int n;//站点数
priority_queue<node> que;
void Dijkstra1(int s)
{
bool vis[MAXN];
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++)
dis1[i]=INF;
while(!que.empty()) que.pop();
dis1[s]=0;
que.push(node(s,0));
while(!que.empty())
{
node u=que.top();
que.pop();
int num=u.num;
if(vis[num]) continue;
vis[num]=1;
for(int i=head1[num];i!=-1;i=edge1[i].next)
{
int to=edge1[i].v;
if(!vis[to]&&dis1[to]>dis1[num]+edge1[i].cost)
{
dis1[to]=dis1[num]+edge1[i].cost;
que.push(node(to,dis1[to]));
}
}
}
}
void Dijkstra2(int s)
{
bool vis[MAXN];
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++)
dis2[i]=INF;
while(!que.empty()) que.pop();
dis2[s]=0;
que.push(node(s,0));
while(!que.empty())
{
node u=que.top();
que.pop();
int num=u.num;
if(vis[num]) continue;
vis[num]=1;
for(int i=head2[num];i!=-1;i=edge2[i].next)
{
int to=edge2[i].v;
if(!vis[to]&&dis2[to]>dis2[num]+edge2[i].cost)
{
dis2[to]=dis2[num]+edge2[i].cost;
que.push(node(to,dis2[to]));
}
}
}
}
void addedge1(int u,int v,int w)
{
edge1[tol1].v=v;
edge1[tol1].cost=w;
edge1[tol1].next=head1[u];
head1[u]=tol1++;
}
void addedge2(int u,int v,int w)
{
edge2[tol2].v=v;
edge2[tol2].cost=w;
edge2[tol2].next=head2[u];
head2[u]=tol2++;
}
int main()
{
int T;
int m;//边数
scanf("%d",&T);
while(T--){
scanf("%d%d",&n,&m);
tol1=tol2=0;
memset(head1,-1,sizeof(head1));
memset(head2,-1,sizeof(head2));
int a,b,c;
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
addedge1(a,b,c);
addedge2(b,a,c);
}
Dijkstra1(1);
Dijkstra2(1);
long long int sum=0;
for(int i=1;i<=n;i++)
sum+=dis1[i]+dis2[i];
printf("%lld\n",sum);
}
return 0;
}