hdu 6186 CS Course (前缀+后缀)

Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,⋯,an, and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.

Input
There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤10^5

Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤10^9 for each i in range[1,n].

After that there are q positive integers p1,p2,⋯,pqin q lines, 1≤pi≤n for each i in range[1,q].

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.

Sample Input
3 3
1 1 1
1
2
3

Sample Output
1 1 0
1 1 0
1 1 0

大致题意:告诉你n个数,q次查询,每次选择一个位置上的数,然后让你求出其他的n-1个数的&,|,^这三种运算的值。

思路:对于异或运算我们知道a^b^b=a,所以我们可以将这n个数的异或值ans记录下来,那么不包含x数的异或值即ans^x。对于另外两种运算,我们可以记录他们的前缀和后缀,具体实现看下面代码

代码如下

#include<iostream>
#include <cstdio>  
#include <algorithm> 
#include <cstring>   
#define LL long long int
const int maxn=1e5+5;
LL p1[maxn],s1[maxn];// 记录&运算的前缀和后缀值 
LL p2[maxn],s2[maxn];// 记录|运算的前缀和后缀值 
int a[maxn];
int main() 
{  
    int n,q;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        LL ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i==1)
                p1[i]=p2[i]=a[i];
            else
            {
                p1[i]=(p1[i-1]&a[i]);
                p2[i]=(p2[i-1]|a[i]);    
            }
            ans^=a[i];
        }

        for(int i=n;i>=1;i--)
        {
            if(i==n)
                s1[i]=s2[i]=a[i];
            else
            {
                s1[i]=(s1[i+1]&a[i]);
                s2[i]=(s2[i+1]|a[i]);
            }
        }
        while(q--)
        {
            int x;
            scanf("%d",&x);
            if(x==1)
            {
                printf("%lld %lld %lld\n",s1[2],s2[2],ans^a[x]);
            }
            else if(x==n)
            {
                printf("%lld %lld %lld\n",p1[n-1],p2[n-1],ans^a[x]);
            }
            else 
            {
                printf("%lld %lld %lld\n",p1[x-1]&s1[x+1],p2[x-1]|s2[x+1],ans^a[x]);
            }
        }
    }
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值